[OZAPRS] Frustration!

Matthew Cook vk5zm at bistre.net
Fri Mar 27 18:31:37 EST 2015


What distro are you using with the BBB?

I'm surprised that you're having so much trouble with the rPi.  I've had an
original Model-B running continuously for the past 2 years without
rebooting (VK5ZM-5 Rx Only iGate), it currently runs a full AX25 stack and
aprx.  The only negative thing I'll say regarding the Pi's is make sure
you're power supply is 5V with NO detectable ripple at 1A output (so <
20mV); otherwise there will be tears.

I also just recently built two more APRS iGates using the latest Model-A's
and a pair of tncPi's.  Both of these are working with the latest version
of Rasberian.

I'd firstly check the 5V supply that you're feeding the rPi with, make sure
it's clean and not drooping under load.   If you can still find one the
Geekroo Echidna PSU shields (http://www.geekroo.com.au/products/526) are
not a bad way of powering your Pi. You can find them a little cheaper
around the traps if you search.   I'll see how small I can compress and
image of my current SD card and if I can sensibly upload it somewhere on
the net, if that will help?

The vast amount of rPi stability issues can be traced to the power supply,
this is the best place to start.  Let me know if you need any more help
sorting your Pi out.



On 24 March 2015 at 11:35, Liz <edodd55 at gmail.com> wrote:

> Problem
> My Rpi stops as and when it feels like - actually there is a race
> problem with the kernel, trying to read the cpu temp every 3 seconds,
> and if it does any real work, it quits in disgust. I was trying to make
> the thing more robust, but it won't even reliably reboot because the SD
> card hasn't been unmounted properly, and hangs on reboot.
> Solution 1
> upgrade to newer kernel
> Effect
> doesn't boot. Trying to direct it an earlier kernel image also fails
> Solution 2
> use the BeagleBoneBlack
> Effect
> worked at first,
> doesn't have ax25 networking built in to the kernel. Tried to rebuild a
> kernel and it fails. Rebooted itself and then wouldn't talk to the radio
> Solution 3
> find another computer.....
> Try to fix one or both of the embedded items.....
> Anyone got any smart ideas about how to get the BBB using aprx to speak
> to the radio again?
> I've tried with and without KISS mode on the radio
> /dev/ttyUSB0 is there - I can access the radio to set KISS mode
> successfully
> power on the USB hub doesn't improve things
> any more ideas?
> Liz
> _______________________________________________
> OZAPRS mailing list
> OZAPRS at aprs.net.au
> http://lists.aprs.net.au/mailman/listinfo/ozaprs
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.aprs.net.au/pipermail/ozaprs/attachments/20150327/be110716/attachment.html>

More information about the OZAPRS mailing list